Commit 85eacf42 authored by Amy Blank's avatar Amy Blank 🌈
Browse files

Merge branch 'feature/specify-versions' into 'devel'

Feature/specify versions

See merge request !1
parents 105407c9 956d9b95
Pipeline #9619 passed with stage
in 27 seconds
......@@ -7,6 +7,6 @@ build:
script:
- ./setup.py install
test:
script:
- ./setup.py test
#test:
# script:
# - ./setup.py test
......@@ -8,10 +8,10 @@ put content here
### Reviewers
- [ ] @cw
- [ ] @tn
- [ ] @amyblank
- [ ] @bz
- [ ] @ps
- [ ] @wd
### Resources
......
......@@ -11,10 +11,10 @@
### Reviewers
- [ ] @cw
- [ ] @tn
- [ ] @amyblank
- [ ] @bz
- [ ] @ps
- [ ] @wd
### Resources and Documentation
> Links for resources and documentation go here.
#!/usr/bin/env python
#!/usr/bin/env python3
from setuptools import setup, find_packages, Command
from distutils.util import convert_path
......@@ -17,18 +17,18 @@ setup(
include_package_data=True,
install_requires=[
'click==6.6',
'click_spinner',
'click_didyoumean',
'semver',
'jinja2',
'canopen',
'PyYaml',
'configparser',
'pykwalify',
'arrow'
'click_spinner==0.1.8',
'click_didyoumean==0.0.3',
'semver==2.8.1',
'jinja2==2.10',
'canopen==0.8.0',
'PyYaml==4.2b4',
'configparser==3.5.0',
'pykwalify==1.7.0',
'arrow==0.12.1'
],
setup_requires=['pytest-runner'],
tests_require=['pytest', 'coverage'],
setup_requires=['pytest-runner==4.2'],
tests_require=['pytest==4.0.1', 'coverage==5.0a4'],
description='Object Dictionary Generator for Barrett Firmware',
author='Christopher Woodall',
author_email='cw@barrett.com',
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment